Symptoms:
On opening V10.1, the Activation dialog displays but is blank, not showing the 'Enter your email address' field. View image
Cause:
The Microsoft Edge WebView2 component is not installed on the machine used to display web content in desktop applications. Learn more about WebView2
Step 1. Clear WebView2 cache (most important step)
Close V10.
Delete the following folder: %LOCALAPPDATA%\Temp\TTSDesktopAuthentication
Then reopen V10 and test activation again.
Step 2. Repair WebView2 Runtime
Even though it says “already installed”, perform a repair:
1. Go to: Control Panel → Programs and Features
2. Locate: Microsoft Edge WebView2 Runtime
3. Right-click → Repair
If “Repair” is not available:
• Uninstall it
• Then reinstall using the standalone Evergreen installer (not bootstrapper): https://developer.microsoft.com/en-us/microsoft-edge/webview2/
Then reopen V10 and test activation again.
Step 3. Check security restrictions (common in schools)
Ask IT to confirm:
• WebView2 is not blocked by:
o Microsoft Defender SmartScreen
o WDAC / AppLocker policies
o Endpoint protection
• The following can run:
o msedgewebview2.exe
o TimetablingSolutionsX.exe
o ActivateSoftware.exe
TIP: V10.1: 'Microsoft Edge can't read and write to its data directory' and a blank Sign in screen
Note: if experiencing the issue on Citrix, you may encounter the msedgewebview2 application constantly crashing. If so, please follow this Citrix KB article https://support.citrix.com/article/CTX107825/how-to-disable-citrix-api-hooks-on-a-perapplication-basis
