Summary:

When sending mass emails from V9 the user receives a prompt which requires them to click Allow or Cancel. Essentially it’s just a warning message saying hey an application is trying to send emails is that ok.


Cause:

Permissions on end users machine


Resolution:

1) Open Outlook 2010, go to "File/Options/Trust Center" menu item, and then click on the "Trust Center Settings" button at the right side of the dialog box.
2) From there, select the "Programmatic Access" menu item. At the bottom of this dialog, note what your "Antivirus status" is. If it is "Invalid" then close Outlook, navigate to where its "OUTLOOK" program icon is on your disk (typically it sits in the "Program Files (x86)/Microsoft Office" folder), and then right-click this icon and select "Run as administrator" from the pop-up-menu. If you get a warning, then select "allow" or "yes" to continue.
3) Then in Outlook, go back to Programmatic Access as described above, and you should see your antivirus status updated to "Valid" (assuming you have an up-to-date antivirus program on your computer).
4) Exit Outlook. Then open it the way you usually do. The warnings should now be gone.
This way, your Outlook application will be protected from malware, and you should no longer see warnings when other applications try to access Outlook.